Sincronizarea vânzărilor din CloudBillPos către BOCP Cloud nu funcționează pe laptop când este pe baterie
Sincronizarea vânzărilor către BOCP Cloud nu funcționează pe laptop când este pe baterie
Problemă
Pe unele laptopuri, atunci când dispozitivul funcționează pe baterie (fără alimentare la priză), vânzările din serverul local nu se mai sincronizează către BOCP Cloud.
Cauză
Windows are o setare implicită care oprește execuția sarcinilor programate atunci când laptopul nu este conectat la sursa de alimentare. Astfel, sarcina programată care se ocupă de trimiterea datelor către cloud („cron task”) nu mai rulează când laptopul este doar pe baterie.
Soluție
Este necesară modificarea setărilor pentru taskul de sincronizare, astfel încât acesta să ruleze indiferent dacă laptopul este pe baterie sau la priză.
Pași de urmat

- Deschide aplicația Task Scheduler (Planificator de activități):
Apasă Start → scrieTask Scheduler→ Enter.
(În română: „Planificator de activități”.) - Accesează folderul cu taskurile BOCP:
În panoul din stânga, mergi la:
Task Scheduler Library → POSTasks
(În română: „Bibliotecă Planificator de activități → POSTasks”.) - Deschide taskul „cron”:
Dă dublu click pe taskul numitcron. - Modifică setările de alimentare:
Mergi la fila Conditions („Condiții”).
În secțiunea Power („Alimentare”):
Debifează opțiunea:
Start the task only if the computer is on AC power
(în română: „Porniți activitatea numai dacă computerul este alimentat de la rețea”).
Apasă OK pentru a salva modificările. - Verifică funcționarea:
Poți forța rularea taskului (cron) manual, cu click dreapta → Run („Executare”), pentru a testa dacă sincronizarea pornește și pe baterie.

Notă
Această modificare nu afectează securitatea sau performanța sistemului. Recomandăm însă să păstrați laptopul alimentat la priză în timpul sincronizărilor mari pentru a evita întreruperile.